Issue with mailing system
Incident Report for Recruitee
Resolved
This incident has been resolved.
Posted Aug 21, 2023 - 23:27 UTC
Identified
We are encountering problems with sending emails through our mailing functionality. We're working to resolve this as soon as possible. We apologize for any inconvenience caused.
Posted Aug 21, 2023 - 22:06 UTC
This incident affected: Recruitee.