Issues with marketing site
Incident Report for Recruitee
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 16:11 UTC
Investigating
Due to technical update in our partner Weglot's services, our deeply integrated localized website is not functioning at 100%. Our recruitee.com/fr, recruitee.com/nl, recruitee.com/de sections are currently unaccessible. We are working closely with the Weglot tech team on solving this as soon as possible.
Posted Nov 09, 2023 - 11:11 UTC